Friday, October 26, 2007

Subclipse - old client?

After updating my Mac with Subversion 1.4.4 and running a status on one of my Java folders I go the following error in Eclipse:

Unsupported working copy format svn: This client is too old to work with working copy '/Users/fred/workspace/Project/lib'; please get a newer Subversion client

Well, I immediately made sure that I was up-to-date, I am running Subclipse 1.2.4. To find your version, go to Help|Software Updates|Manage Configuration. You will see your version number there.

Obviously Subclipse 1.2.4 is running the old Sunversion client. I searched in several places to try to find a newer version but to no avail. I then explored SVNKit and found instructions for switching it on in Subclipse. SVNKit uses the newer Subversion 1.4 protocol and comes with Subclipse but it is not enabled by default.

To turn SVNKit on, goto Eclipse preferences and select SVNKit under the SVN option:

Click OK and you are ready to go with the latest version of SVN under Eclipse.

You will be asked to enter your password again or to choose your private key to use with the remote site if you are using ssh.